Replay Mod Forums

1.8.9 Replay Mod + Liteloader?
    • User
    • 3 forum posts
    Reeses
    #1

    Oct 11 17, 11:07 PM

    Hey, I was wondering if there is any version of the Replay Mod in 1.8.9 that is compatible with LiteLoader?
    Unfortunately, LiteLoader is required for one of my mods (TabbyChat 2.0) and it is a mod that I have grown to need in order to tolerate moderating a large server's chat.
    I read that it is possible to have both Replay Mod and LiteLoader in 1.10, but the server I play on is 1.8.9 based PvP.

    Fingers crossed that there is a solution~


    • Moderator
    • Beta Tester
    • 357 forum posts
    bela333
    #2

    Oct 12 17, 05:25 PM

    As far as I know LiteLoader has Forge support so it shouldn't be a problem


    • User
    • 3 forum posts
    Reeses
    #3

    Oct 12 17, 10:45 PM

    Forge does, but Replay Mod doesn't.
    The replay mod and forge work with all of my mods until I start the game with a forge + liteloader version.


    • Developer
    • 1618 forum posts
    johni0702
    #4

    Oct 13 17, 08:39 PM

    Any version should work but I've just tested it and can confirm that (at least) the latest (1.8.9) version of RM gets ignored by Forge when LiteLoader is installed. I'll look into it once I find the time to do so.


    • User
    • 3 forum posts
    Reeses
    #5

    Oct 14 17, 06:32 AM

    Thank you! Would be awesome to be able to use these mods combined



    • User
    • 5 forum posts
    Ynng11626
    #6

    Nov 05 17, 04:12 PM

    I just had the same issue and I really want to use replay mod as soon as possible. Please fix this issue.


    • Developer
    • 1618 forum posts
    johni0702
    #7

    Nov 06 17, 09:50 PM

    Afaict this is caused by the ancient 1.8.9 LiteLoader shipping with an equally ancient Mixin lib (version 0.5.3) that is too old to work with the ReplayMod.
    ReplayMod ships with its own version of the Mixin lib but that's not getting used because LiteLoader is being loaded first.
    Once way to work around that is to install LiteLoader as a Forge mod as described here.
    There is nothing we could change in the ReplayMod to automatically fix the problem, so above workaround will be required until LiteLoader releases an updated 1.8.9 version (which is probably never going to happen).


    • User
    • 5 forum posts
    Ynng11626
    #8

    Nov 14 17, 11:20 PM

    I just tried loading liteloader as a forge mod but it didn't work. However, since you mentioned the order the mods are being loaded, I searched around the web and in a post on minecraftforge.com, someone indicated that forge load mods in alphabetical order if the mod doesn't specify the priority, so I add a "A" in front of the Replay mods' jar file file name. And you know what, It works!
    I'm still testing all the functions of the mods to make sure I won't crash in game, but.... yhea.. it works after loading liteloader as a forge mod and changing the mods file name. Just want to help any one who didn't know the name changing thing...


    • User
    • 5 forum posts
    Ynng11626
    #9

    Nov 14 17, 11:34 PM

    Just found a problem/bug, Since it's probably caused by liteloader, I won't put it in the "report bug", and I don't expect it to be fixed......
    So....when you're veiwing a replay and you release mouse using the chat button, I will only be able to click once, then my mouse doesn't do anything. I have to press "p" twize to "refresh" the mod (what I think) for my mouse to click again.....
    I'm kind of fine with it though....
    yhea..


    • User
    • 5 forum posts
    Ynng11626
    #10

    Nov 14 17, 11:37 PM

    Recording works fine..



    • User
    • 1 forum post
    solonovamax

    in response to Ynng11626

    #11

    May 11 19, 10:11 PM | Last edited: May 11 19, 10:11 PM


    I just tried loading liteloader as a forge mod but it didn't work. However, since you mentioned the order the mods are being loaded, I searched around the web and in a post on minecraftforge.com, someone indicated that forge load mods in alphabetical order if the mod doesn't specify the priority, so I add a "A" in front of the Replay mods' jar file file name. And you know what, It works!
    I'm still testing all the functions of the mods to make sure I won't crash in game, but.... yhea.. it works after loading liteloader as a forge mod and changing the mods file name. Just want to help any one who didn't know the name changing thing...


    Ok, I just want to say, that this solution right here is the oddest solution ever (coming from a programmer's perspective), yet somehow THIS is the thing that worked above all other things.

    Thanks for the tip