Replay Mod Forums

Replay mod wont let me use the trim replay
    • User
    • 2 forum posts
    Thomas200509
    #1

    Jan 12 19, 05:45 PM

    Replay mod wont let me use the trim replay feature. I am on the latest replay mod for 1.8.9 and got the latest java the error is

    ---- Minecraft Crash Report ----

    WARNING: coremods are present:
    OpenEyePlugin (OpenEye.jar)
    LoadingPlugin (replaymod-1.8.9-2.1.4.jar)
    Contact their authors BEFORE contacting forge

    // You should try our sister game, Minceraft!

    Time: 1/12/19 4:43 PM
    Description: Editing replay file

    java.lang.RuntimeException: java.io.IOException: decoding
    at com.replaymod.replaystudio.studio.StudioPacketStream.nextInput(StudioPacketStream.java:56)
    at com.replaymod.replaystudio.stream.AbstractPacketStream.next(AbstractPacketStream.java:260)
    at com.replaymod.editor.gui.GuiReplayEditor.lambda$2(GuiReplayEditor.java:165)
    at com.replaymod.editor.gui.GuiReplayEditor$$Lambda$53/1519114227.accept(Unknown Source)
    at com.replaymod.editor.gui.GuiReplayEditor$2.lambda$0(GuiReplayEditor.java:255)
    at com.replaymod.editor.gui.GuiReplayEditor$2$$Lambda$57/1487576229.run(Unknown Source)
    at com.replaymod.editor.gui.GuiReplayEditor.lambda$5(GuiReplayEditor.java:276)
    at com.replaymod.editor.gui.GuiReplayEditor$$Lambda$58/1173060930.run(Unknown Source)
    at java.lang.Thread.run(Thread.java:745)
    Caused by: java.io.IOException: decoding
    at com.replaymod.replaystudio.io.ReplayInputStream.fillBuffer(ReplayInputStream.java:195)
    at com.replaymod.replaystudio.io.ReplayInputStream.readPacket(ReplayInputStream.java:146)
    at com.replaymod.replaystudio.studio.StudioPacketStream.nextInput(StudioPacketStream.java:54)
    ... 8 more
    Caused by: java.lang.ArrayIndexOutOfBoundsException
    at java.lang.System.arraycopy(Native Method)
    at com.replaymod.lib.com.github.steveice10.mc.protocol.util.NetUtil.dataToChunks(NetUtil.java:219)
    at com.replaymod.lib.com.github.steveice10.mc.protocol.packet.ingame.server.world.ServerChunkDataPacket.read(ServerChunkDataPacket.java:109)
    at com.replaymod.lib.com.github.steveice10.packetlib.tcp.TcpPacketCodec.decode(TcpPacketCodec.java:41)
    at com.replaymod.replaystudio.studio.protocol.StudioCodec.decode(StudioCodec.java:42)
    at com.replaymod.replaystudio.io.ReplayInputStream.fillBuffer(ReplayInputStream.java:191)
    ... 10 more

    A detailed walkthrough of the error, its code path and all known details is as follows:
    ---------------------------------------------------------------------------------------

    -- System Details --
    Details:
    Minecraft Version: 1.8.9
    Operating System: Windows 10 (amd64) version 10.0
    CPU: 12x Intel(R) Core(TM) i7-8700K CPU @ 3.70GHz
    Java Version: 1.8.0_51, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 667847448 bytes (636 MB) / 1855979520 bytes (1770 MB) up to 3817865216 bytes (3641 MB)
    JVM Flags: 4 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx4096m -Xms256m -XX:PermSize=256m
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    FML: MCP 9.19 Powered by Forge 11.15.1.2318 Optifine OptiFine_1.8.9_HD_U_I7 13 mods loaded, 13 mods active
    States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
    UCHIJA mcp{9.19} [Minecraft Coder Pack] (minecraft.jar)
    UCHIJA FML{8.0.99.99} [Forge Mod Loader] (forge-1.8.9-11.15.1.2318-1.8.9.jar)
    UCHIJA Forge{11.15.1.2318} [Minecraft Forge] (forge-1.8.9-11.15.1.2318-1.8.9.jar)
    UCHIJA OpenEye{0.8} [OpenEye] (OpenEye.jar)
    UCHIJA replaymod-compat{1.8.9-2.1.4} [Replay Mod - Compatibility] (replaymod-1.8.9-2.1.4.jar)
    UCHIJA replaymod{1.8.9-2.1.4} [Replay Mod] (replaymod-1.8.9-2.1.4.jar)
    UCHIJA replaymod-editor{1.8.9-2.1.4} [Replay Mod - Replay Editor] (replaymod-1.8.9-2.1.4.jar)
    UCHIJA replaymod-extras{1.8.9-2.1.4} [Replay Mod - Extras] (replaymod-1.8.9-2.1.4.jar)
    UCHIJA replaymod-online{1.8.9-2.1.4} [Replay Mod - Online] (replaymod-1.8.9-2.1.4.jar)
    UCHIJA replaymod-recording{1.8.9-2.1.4} [Replay Mod - Recording] (replaymod-1.8.9-2.1.4.jar)
    UCHIJA replaymod-render{1.8.9-2.1.4} [Replay Mod - Render] (replaymod-1.8.9-2.1.4.jar)
    UCHIJA replaymod-replay{1.8.9-2.1.4} [Replay Mod - Replay] (replaymod-1.8.9-2.1.4.jar)
    UCHIJA replaymod-simplepathing{1.8.9-2.1.4} [Replay Mod - Simple Pathing] (replaymod-1.8.9-2.1.4.jar)
    Loaded coremods (and transformers):
    OpenEyePlugin (OpenEye.jar)
    openeye.asm.MultiTransformer
    LoadingPlugin (replaymod-1.8.9-2.1.4.jar)

    GL info: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.
    OptiFine Version: OptiFine_1.8.9_HD_U_I7
    Render Distance Chunks: 32
    Mipmaps: 4
    Anisotropic Filtering: 1
    Antialiasing: 0
    Multitexture: false
    Shaders: null
    OpenGlVersion: 4.6.0 NVIDIA 399.24
    OpenGlRenderer: GeForce GTX 1070 Ti/PCIe/SSE2
    OpenGlVendor: NVIDIA Corporation
    CpuCount: 12


    • Developer
    • 1559 forum posts
    johni0702
    #2

    Feb 01 19, 12:29 AM

    Looks like there's something in the replay which we didn't expect. We'll need the replay file for futher debugging.
    Be aware though that considering the age of 1.8.9 and that this particular issue is probably quite rare, fixing it won't be high on the TODO list.