Replay Mod Forums

Crash in 1.7.10
    • User
    • 5 forum posts
    Crazy_Eddie
    #1

    Feb 10 19, 12:59 AM

    I'm working on a new modpack for an old version and this time, I wanted to see if I can make it compatible with Replay, but during testing, after walking around a bit, I keep getting this error.

    Spoiler: Crash Report


    I really hope it's not just incompatible with Reika's mods, but I haven't tested yet to see whether it still crashes when I'm not recording or if I stay in a loaded area. It does only seem to happen when Replay is running. Have you seen anything like this?


    • User
    • 5 forum posts
    Crazy_Eddie
    #2

    Feb 10 19, 01:46 AM

    I've tested a little further and it seems to be Geostrata. I can live without that one, so I guess this bug's just a curiosity at this point.


    • User
    • 5 forum posts
    Crazy_Eddie
    #3

    Feb 10 19, 04:04 AM | Last edited: Feb 10 19, 05:25 AM

    Nevermind, it's still crashing, just maybe not as often...It seems to be both GeoStrata and Chromaticraft. Not sure what to do about that. I really want Chromaticraft in my pack.


    • Developer
    • 1883 forum posts
    johni0702
    #4

    Feb 10 19, 10:53 AM

    Afaict from looking at the crash report, to reliable reproduce it, try drinking a potion (or apply any potion effect to any entity; I'd imagine one of e.g. TC's entities randomly spawned which triggered it for you).
    Some mod fiddles with the EntityEffectPacket, removing (or maybe renaming) a vital method (might also be caused by incompatible Forge version, though yours seems like the best choice). IIRC the RM doesn't directly touch it.
    The full game log might contain a hint at the cause (the forum has a post length limit, you can instead paste it to https://paste.replaymod.com/). If it doesn't, and you can indeed reproduce it reliably, then the only other way to find the cause is to simplify the modpack until only RM + offending mod remains.