Replay Mod Forums

Disappearing Players
    • User
    • 3 forum posts
    TotiGonzales
    #1

    Oct 07 18, 11:31 PM

    Hey everyone!

    I've been using the replay mod for a while now and other than the usual crashing the game when clicking on the export destination with a shader on or crashing the game when exporting with the same name as another file, I never encountered any major bugs that would completely interrupt my workflow. Up until 1 week ago when I started working on this replay of a recording from an online event. Everything works fine other than this 1 player (the most important one that has to be in the render) who keeps disappearing. He disappears during the replay at times but at other times he doesn't and sometimes when he doesn't disappear in the replay he is invisible in the render or the other way around. I've been trying to solve this for the past couple of days or work around it but it is getting really frustrating.

    Data:
    Minecraft 1.12.2
    Forge 1.12.2 - 14.23.2.2611
    Replay Mod every version starting with 1.12.2-2.0.1 (tho it was recorded on the latest version 2.1.4 I believe)

    The deadline for this video is approaching quickly and it would be amazing if you could help me solve this.

    Cheers
    Toti


    • Developer
    • 1883 forum posts
    johni0702
    #2

    Oct 08 18, 03:36 PM

    Make sure you have the latest version of RM, the latest "Recommended" build of Forge and no other mods installed before proceeding. All of those issues (except the same name thing) sound like things I've previously fixed. Though I guess shaders could have broken it again, wouldn't be the first time that happened.

    Please post the contents of the fml-client-latest.log file inside the logs folder inside your .minecraft folder to some pastebin site and link to the post here.

    Note that this log will only contain information on the last time you started Minecraft, not any previous runs.

    Please also upload the replay (either to the Replay Center or some other file hosting site) and link to it so we can try ourselves. It'd also be handy if you can provide concrete steps using which you're able to reliably reproduce the bug (e.g. open replay, pause, jump to time X, jump to player Y, play for 30 secs, player Y disappears).


    • User
    • 3 forum posts
    TotiGonzales
    #3

    Oct 10 18, 09:11 PM | Last edited: Oct 10 18, 09:18 PM

    Thanks for the quick response!
    After updating to the latest (recommended) forge version and removing all other mods from the folder (including optifine which didn't allow me to try this out with shaders) the issue with the disappearing player seems to have been solved in the replay viewer. And I say only in the replay viewer because every time I tried to render out a camera path the game crashed at the exact moment I clicked on the render path selection button. I thought this was a problem with shaders before but this time I didn't have any. And it didn't happen every now and then, it happened every time I tried to render something. So I can't tell if the player shows up in the render yet but here is the stuff u asked me to share:

    Link to the text from latest.log as fml-client-latest.log didn't seem to work with the latest version of forge.

    Also, I uploaded it to the replay center where you can find it under the name of "Closing Ceremony" it's by TotiGonzales.

    Here is the crash report too.

    Thanks for the help!
    Toti


    • User
    • 3 forum posts
    gerard_wensink
    #4

    Sep 14 19, 07:22 PM

    Same here on 1.12.2
    In 1.14.4 the player is visible, but when pressing right mouse button it should follow / spectate players and/or entities.
    But that also does not work.
    Also ReplayMod can not be compiled after cloning.
    It really sucks.