Replay Mod Forums

Crash window when saving replay file
    • User
    • 2 forum posts
    VivAndroid_07
    #1

    Jul 07 19, 12:37 PM

    Hi. When i stop recording and Replay Mod saves, the mod crashes and showing a window with a log and two buttons which say: Copy to clipboard, Back.
    But the game works! And i can't view my replay!

    This is the log:

    ---- Minecraft Crash Report ----

    WARNING: coremods are present:
    LoadingPlugin (replaymod-1.12.2-2.2.0-b5.jar)
    Contact their authors BEFORE contacting forge

    // My bad.

    Time: 7/7/19 12:22 PM
    Description: Saving replay file

    java.io.IOException: decoding
    at com.replaymod.replaystudio.io.ReplayInputStream.fillBuffer(ReplayInputStream.java:233)
    at com.replaymod.replaystudio.io.ReplayInputStream.readPacket(ReplayInputStream.java:184)
    at com.replaymod.editor.gui.MarkerProcessor.apply(MarkerProcessor.java:146)
    at com.replaymod.recording.packet.PacketListener.lambda$channelInactive$8(PacketListener.java:220)
    at com.replaymod.recording.packet.PacketListener$$Lambda$305/1484859619.run(Unknown Source)
    at java.lang.Thread.run(Thread.java:745)
    Caused by: java.lang.IllegalArgumentException: Value forge.swimSpeed has no mapping for key class com.replaymod.lib.com.github.steveice10.mc.protocol.data.game.entity.attribute.AttributeType.
    at com.replaymod.lib.com.github.steveice10.mc.protocol.data.MagicValues.key(MagicValues.java:1081)
    at com.replaymod.lib.com.github.steveice10.mc.protocol.packet.ingame.server.entity.ServerEntityPropertiesPacket.read(ServerEntityPropertiesPacket.java:51)
    at com.replaymod.lib.com.github.steveice10.packetlib.tcp.TcpPacketCodec.decode(TcpPacketCodec.java:41)
    at com.replaymod.replaystudio.studio.protocol.StudioCodec.decode(StudioCodec.java:42)
    at com.replaymod.replaystudio.io.ReplayInputStream.fillBuffer(ReplayInputStream.java:229)
    ... 5 more

    A detailed walkthrough of the error, its code path and all known details is as follows:
    ---------------------------------------------------------------------------------------

    -- System Details --
    Details:
    Minecraft Version: 1.12.2
    Operating System: Windows 10 (amd64) version 10.0
    Java Version: 1.8.0_51, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 296677304 bytes (282 MB) / 671088640 bytes (640 MB) up to 1073741824 bytes (1024 MB)
    JVM Flags: 8 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx1G -XX:+UnlockExperimentalVMOptions -XX:+UseG1GC -XX:G1NewSizePercent=20 -XX:G1ReservePercent=20 -XX:MaxGCPauseMillis=50 -XX:G1HeapRegionSize=32M
    IntCache: cache: 0, tcache: 0, allocated: 13, tallocated: 95
    FML: MCP 9.42 Powered by Forge 14.23.5.2768 Optifine OptiFine_1.12.2_HD_U_E3 5 mods loaded, 5 mods active
    States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored

    | State | ID | Version | Source | Signature |
    |:----------- |:--------- |:--------------- |:----------------------------- |:---------------------------------------- |
    | UCHIJAAAAAA | minecraft | 1.12.2 | minecraft.jar | None |
    | UCHIJAAAAAA | mcp | 9.42 | minecraft.jar | None |
    | UCHIJAAAAAA | FML | 8.0.99.99 | forge-1.12.2-14.23.5.2768.jar | e3c3d50c7c986df74c645c0ac54639741c90a557 |
    | UCHIJAAAAAA | forge | 14.23.5.2768 | forge-1.12.2-14.23.5.2768.jar | e3c3d50c7c986df74c645c0ac54639741c90a557 |
    | UCHIJAAAAAA | replaymod | 1.12.2-2.2.0-b5 | replaymod-1.12.2-2.2.0-b5.jar | None |

    Loaded coremods (and transformers):
    LoadingPlugin (replaymod-1.12.2-2.2.0-b5.jar)

    GL info: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.

    Someone can help me?


    • Developer
    • 1741 forum posts
    johni0702
    #2

    Jul 07 19, 12:45 PM | Last edited: Jul 07 19, 12:46 PM

    Thanks for reporting this issue! I'm fairly certain that I know what's causing it and should be able to fix it in the next version.

    There's a high chance you'll be able to recover your replay. Have a look into ".minecraft/replay_recordings/raw", if you can find your replay in there, simply move it up one folder and you should be able to access it again.
    Be sure to nevertheless report any other such issues, even if this workaround works for them. The only exception ofc is if it's the exact same issue, i.e. "Caused by: java.lang.IllegalArgumentException: Value forge.swimSpeed has no mapping for key class com.replaymod.lib.com.github.steveice10.mc.protocol.data.game.entity.attribute.AttributeType." with 2.2.0-b5 or older.


    • User
    • 2 forum posts
    VivAndroid_07
    #3

    Jul 11 19, 01:33 PM

    Thank you for help!