Replay Mod Forums

Instant crashing while trying to load a replay
    • User
    • 9 forum posts
    Chrvz
    #1

    Jul 07 19, 08:40 PM

    Hello,
    so I have the problem that the mod always crashed while trying to load a clip. Im using Minecraft 1.7.10 and I made sure im using Java, Forge and Replaymod all in the newest version available. I tried using different versions of the mod which sometimes worked but inconsistently.
    Firstly the mod was working fine and I was trying to figure out a way to use the mod combined with bettersprint. After a while the crashed occured even without any other mods than replaymod and now I'm unable to fix the crashes. I made sure to start the mod with deleting all related files in the minecraftfolder and tried around with videosettings and the mods settings. I wasnt able to get into a replay since then.

    Spoiler: Log


    • User
    • 9 forum posts
    Chrvz
    #2

    Jul 07 19, 10:24 PM | Last edited: Jul 07 19, 10:28 PM

    So I randomly tried going into a replay without any other mods and it perfectly worked.
    After trying to combine it with Optifine (HD_U_E7) it crashed even after removing it again.

    - So even later I began to play around with the minecraft graphic settings and found one that seems working with optifine.

    Spoiler: Working try


    • User
    • 9 forum posts
    Chrvz
    #3

    Jul 07 19, 10:29 PM

    Spoiler: Crashing Try (Since I cant put 2 spoilers in one post)


    • Developer
    • 1741 forum posts
    johni0702
    #4

    Jul 08 19, 12:37 PM

    That sounds like a timing sensitive issue and indeed, while trying to reproduce it by adding artificial delays, I can across a race condition issue.
    The crash looks different for me but I strongly suspect its cause is the same.
    Here's a snapshot which includes a fix for it, please give it a try and report back whether it fixes your issue: https://minio.johni0702.de/replaymod/replaymod-1.7.10-2.2.0-b5-4-gac60e58.jar
    (if required you can also get it for any other supported MC version by modifying the URL accordingly)


    • User
    • 9 forum posts
    Chrvz
    #5

    Jul 08 19, 01:09 PM

    Im impressed!
    I wasnt able to recreate any of the crashes even with togglesprint.
    Thank you very much, that was fast! I appreciate you taking the time.



    • User
    • 9 forum posts
    Chrvz
    #6

    Jul 08 19, 01:22 PM

    After testing around a bit, I noticed that the game freezes when I try using the timeline. I will post a youtube link where I record the problem after its uploaded


    • User
    • 9 forum posts
    Chrvz
    #7

    Jul 08 19, 01:42 PM

    Spoiler: The Log when the game freezes


    • User
    • 9 forum posts
    Chrvz
    #8

    Jul 08 19, 01:42 PM

    Spoiler: Video


    • Developer
    • 1741 forum posts
    johni0702
    #9

    Jul 08 19, 01:44 PM | Last edited: Jul 08 19, 02:00 PM

    The log has been cut short, please post it to https://paste.replaymod.com/ and then link that instead so the forum doesn't screw it up.
    Edit: Not necessary. Thanks to the video I was able to (at least once, I tried random jumping before and that didn't do it) reproduce the issue.


    • User
    • 9 forum posts
    Chrvz
    #10

    Jul 08 19, 02:03 PM

    Heres the log anyways, maybe it will help you :)

    https://paste.replaymod.com/lomexucugu



    • Developer
    • 1741 forum posts

    • User
    • 9 forum posts
    Chrvz
    #12

    Jul 08 19, 04:04 PM

    I just tried around abit and didnt notice any further issues. Thank you for that great support!