Replay Mod Forums

1.13.2?
    • User
    • 6 forum posts
    Mayor05
    #1

    Jul 24 19, 03:58 PM

    PLEASE add a replay mod 1.13.2, don’t skip it because I desperately need it for many reasons, if it is coming out is there an estimated date?


    • Developer
    • 1882 forum posts
    johni0702
    #2

    Jul 24 19, 05:01 PM

    Name me one good reason.

    Also, afaik Mixin still doesn't work with the new Forge and Mixin is a hard requirement for me to even consider it.


    • User
    • 6 forum posts
    Mayor05

    in response to johni0702

    #3

    Jul 25 19, 12:39 AM | Last edited: Jul 25 19, 12:56 AM


    Name me one good reason.

    Also, afaik Mixin still doesn't work with the new Forge and Mixin is a hard requirement for me to even consider it.
    The server that I work for required 1.13.2, I have asked them several times to change it to a different version that was compatible with the replay mod but they refused because it world make the server crash, not even me, but many more people would like to see a replay mod 1.13.2 and some desperately need it as well, I know people that do. Doing this could probably help the replay mod in many ways as in many people would like to download and visit the website. All your hard work would be greatly paid off and appreciated. The version would be greatly appreciated by many people who love to use the replay mod as I do. Please, please, please make a replay mod 1.13.2, I beg you!


    • Developer
    • 1882 forum posts
    johni0702
    #4

    Jul 25 19, 09:23 AM | Last edited: Jul 25 19, 09:25 AM

    Some server refusing to upgrade is not a good reason for me to put in the work to downgrade the RM, they should instead just fix their stuff and upgrade (or install ViaVersion).

    Any additional RM version not only has an upfront cost of porting (which I'm not willing to pay myself unless it's to the latest version; 1.7.10 was and will be the only exception because of its unique place in modding), it also incurs an additional maintenance burden for practically forever. We're currently at 11 supported version which is already bad enough, and since I'm the one who is maintaining the mod, the same applies as for the upfront cost.

    I'm not lacking inspiration, I'm lacking motivation for spending my time on it.

    There's also still the issue that it's not technically feasible right now, so the upfront cost would be significantly increased by having to figure out some way to get Mixin to work on the new Forge.


    • User
    • 1 forum post
    BBmanCrafter
    #5

    Aug 19 19, 01:44 PM | Last edited: Aug 19 19, 01:44 PM

    I have one reason for this theme. 1.14-1.14.4 are still little bit unstable versions for some people and servers and they are still using 1.13-1.13.2 or lower, so i want to record with my friends some games, builds and other things, but we don't want to use low versions, but not even 1.14 and higher (for now).

    So.. will you do RM for 1-13-1.13.2 please ?