Replay Mod Forums

My Game Crashes Every Time I Click Render
    • User
    • 1 forum post
    Turbotot
    #1

    Sep 12 19, 06:08 PM | Last edited: Sep 12 19, 06:09 PM

    For a while now I've been trying to make a cinematic replay render thing. This is my first time using replay mod so I'm super confused and in need of help. Basically, whenever I go to render it I open the gui and click render and it loads in the rendering screen but then instantly crashes. It's been a struggle making this replay because this is my first time and other times in the past that I've tried it I've had issues. But now I finally managed to make it and then this happens. Any help would be greatly appreciated. Thanks. (Also I'm kinda short on time because this was for a 200 sub special but it's already been a week since I hit it and I don't wanna keep my viewers waiting).

    EDIT: I'd also just installed the newest ffmpeg and replay mod versions for 1.8.9

    Crash Report:

    ---- Minecraft Crash Report ----
    // This doesn't make any sense!

    Time: 9/12/19 9:53 AM
    Description: Saving replay file

    io.netty.handler.codec.EncoderException: com.replaymod.lib.com.github.steveice10.mc.protocol.packet.ingame.server.scoreboard.ServerTeamPacket@mcsoapthgr8a8edebc[name=mnok6w5mi9,action=CREATE,displayName=mnok6w5mi9,prefix=,suffix=,friendlyFire=false,seeFriendlyInvisibles=false,nameTagVisibility=NEVER,color=,players={96kca4exw6}]
    at com.replaymod.replaystudio.io.ReplayOutputStream.doWrite(ReplayOutputStream.java:227)
    at com.replaymod.replaystudio.io.ReplayOutputStream.write(ReplayOutputStream.java:202)
    at com.replaymod.editor.gui.MarkerProcessor.apply(MarkerProcessor.java:143)
    at com.replaymod.recording.packet.PacketListener.lambda$channelInactive$8(PacketListener.java:225)
    at com.replaymod.recording.packet.PacketListener$$Lambda$99/1072319001.run(Unknown Source)
    at java.lang.Thread.run(Thread.java:745)
    Caused by: java.lang.NullPointerException
    at com.replaymod.lib.com.github.steveice10.mc.protocol.packet.ingame.server.scoreboard.ServerTeamPacket.write(ServerTeamPacket.java:154)
    at com.replaymod.lib.com.github.steveice10.packetlib.tcp.TcpPacketCodec.encode(TcpPacketCodec.java:27)
    at com.replaymod.replaystudio.io.ReplayOutputStream.doWrite(ReplayOutputStream.java:225)
    ... 5 more

    A detailed walkthrough of the error, its code path and all known details is as follows:
    ---------------------------------------------------------------------------------------

    -- System Details --
    Details:
    Minecraft Version: 1.8.9
    Operating System: Windows 10 (amd64) version 10.0
    Java Version: 1.8.0_51, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 409906936 bytes (390 MB) / 704643072 bytes (672 MB) up to 2147483648 bytes (2048 MB)
    JVM Flags: 8 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx2G -XX:+UnlockExperimentalVMOptions -XX:+UseG1GC -XX:G1NewSizePercent=20 -XX:G1ReservePercent=20 -XX:MaxGCPauseMillis=50 -XX:G1HeapRegionSize=32M
    IntCache: cache: 0, tcache: 0, allocated: 13, tallocated: 95
    FML: MCP 9.19 Powered by Forge 11.15.1.1722 4 mods loaded, 4 mods active
    States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
    UCHIJA mcp{9.19} [Minecraft Coder Pack] (minecraft.jar)
    UCHIJA FML{8.0.99.99} [Forge Mod Loader] (forge-1.8.9-11.15.1.1722.jar)
    UCHIJA Forge{11.15.1.1722} [Minecraft Forge] (forge-1.8.9-11.15.1.1722.jar)
    UCHIJA replaymod{1.8.9-2.2.0-b7} [Replay Mod] (replaymod-1.8.9-2.2.0-b7.jar)
    Loaded coremods (and transformers):
    LoadingPlugin (replaymod-1.8.9-2.2.0-b7.jar)

    GL info: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.