Replay Mod Forums

replaymod keeps crashing when saving clip
    • User
    • 4 forum posts
    _Chaarr
    #1

    Oct 02 19, 10:17 AM

    Hi,

    I've started recording clips on hypixel and after going to disconnect and waiting for them to save, it comes up with a crash report of replaymod but doesn't crash my game. I've tried making the clips shorter but the same problem occurs.

    When going to stop the recording I go to the menu and click stop recording then disconnect from the server. I then am on the main menu and it says Saving Replay File... in the top corner and then comes up with the crash report.

    This is the photo of the crash report that comes up on minecraft: https://imgur.com/l33UUVg

    Other mods used: optifine, forge

    This is the crashreport:

    ---- Minecraft Crash Report ----

    WARNING: coremods are present:
    LoadingPlugin (replaymod-1.8-2.2.0-b7 (1).jar)
    Contact their authors BEFORE contacting forge

    // I let you down. Sorry :(

    Time: 2/10/19 6:04 PM
    Description: Saving replay file

    io.netty.handler.codec.EncoderException: com.replaymod.lib.com.github.steveice10.mc.protocol.packet.ingame.server.scoreboard.ServerTeamPacket@TheAslerac97c2dd[name=gh0392q29x,action=CREATE,displayName=gh0392q29x,prefix=,suffix=,friendlyFire=false,seeFriendlyInvisibles=false,nameTagVisibility=NEVER,color=,players={s5s8dt29ol}]
    at com.replaymod.replaystudio.io.ReplayOutputStream.doWrite(ReplayOutputStream.java:227)
    at com.replaymod.replaystudio.io.ReplayOutputStream.write(ReplayOutputStream.java:202)
    at com.replaymod.editor.gui.MarkerProcessor.apply(MarkerProcessor.java:143)
    at com.replaymod.recording.packet.PacketListener.lambda$channelInactive$8(PacketListener.java:225)
    at com.replaymod.recording.packet.PacketListener$$Lambda$101/1174207793.run(Unknown Source)
    at java.lang.Thread.run(Thread.java:745)
    Caused by: java.lang.NullPointerException
    at com.replaymod.lib.com.github.steveice10.mc.protocol.packet.ingame.server.scoreboard.ServerTeamPacket.write(ServerTeamPacket.java:154)
    at com.replaymod.lib.com.github.steveice10.packetlib.tcp.TcpPacketCodec.encode(TcpPacketCodec.java:27)
    at com.replaymod.replaystudio.io.ReplayOutputStream.doWrite(ReplayOutputStream.java:225)
    ... 5 more

    A detailed walkthrough of the error, its code path and all known details is as follows:
    ---------------------------------------------------------------------------------------

    -- System Details --
    Details:
    Minecraft Version: 1.8
    Operating System: Windows 10 (amd64) version 10.0
    Java Version: 1.8.0_51, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 1534385160 bytes (1463 MB) / 2021130240 bytes (1927 MB) up to 3801088000 bytes (3625 MB)
    JVM Flags: 1 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump
    IntCache: cache: 0, tcache: 47, allocated: 13, tallocated: 95
    FML: MCP v9.10 FML v8.0.99.99 Minecraft Forge 11.14.4.1577 Optifine OptiFine_1.8_HD_U_I7 4 mods loaded, 4 mods active
    States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
    UCHIJA mcp{9.05} [Minecraft Coder Pack] (minecraft.jar)
    UCHIJA FML{8.0.99.99} [Forge Mod Loader] (forge-1.8-11.14.4.1577.jar)
    UCHIJA Forge{11.14.4.1577} [Minecraft Forge] (forge-1.8-11.14.4.1577.jar)
    UCHIJA replaymod{1.8-2.2.0-b7} [Replay Mod] (replaymod-1.8-2.2.0-b7 (1).jar)
    Loaded coremods (and transformers):
    LoadingPlugin (replaymod-1.8-2.2.0-b7 (1).jar)

    GL info: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.

    Thanks.