Replay Mod Forums

Crash when rendering - libffi not found
    • User
    • 2 forum posts
    Heliax11
    #1

    Oct 17 19, 11:52 PM

    Trying to render a replay on OSX 10.14.5. I will see the progress bar for the render, then it will say "Saving World" and crash. Based on other report of that I looked at the crash report and export.log.

    export.log

    dyld: Library not loaded: /usr/local/opt/libffi/lib/libffi.6.dylib
    Referenced from: /usr/local/opt/p11-kit/lib/libp11-kit.0.dylib
    Reason: image not found


    I tried `brew install libffi` but it already existed. However, it wasn't linked. I tried to link it but got this message as a response.


    Warning: Refusing to link macOS-provided software: libffi
    For compilers to find libffi you may need to set:
    export LDFLAGS="-L/usr/local/opt/libffi/lib"


    I tried adding the export statement to no avail. How can I make ffmpeg see this libffi? Crash report below.

    Spoiler: Crash Report


    • User
    • 2 forum posts
    Heliax11
    #2

    Oct 21 19, 11:03 PM

    Fixed it. Following the advice from this thread, I removed the ffmpeg installed with brew and downloaded a pre-configured executable. Put it in /usr/local/bin and it's rendering successfully now.