Replay Mod Forums

Replay Mod Causes SevTech Ages to Crash
    • User
    • 4 forum posts
    Danbearpig
    #1

    Apr 20 19, 12:28 AM | Last edited: Apr 23 19, 08:44 PM

    I successfully installed Replay Mod to SevTech 3.0.8, but when adding any combination of Replay Mod version, Forge version (I've tried half a dozen, including recommended, most recent, and packaged with Twitch launcher), and OptiFine (D1 crashes it but E3 works), I get a crash when trying to load data about rendering tipped arrows:

    [edit: cut the crash report, it's in a pastebin link in a later comment now]

    Any insight?


    • Developer
    • 1883 forum posts
    johni0702
    #2

    Apr 20 19, 10:31 AM

    Try removing other mods until you're left with only RM + the conflicting mod(s). If you want to be efficient about it, throw out half of the mods at once and depending on whether it still crashes, continue with the remaining ones or the ones just thrown out.
    Once done:

    Please post the contents of the fml-client-latest.log file inside the logs folder inside your .minecraft folder to some pastebin site and link to the post here.

    Note that this log will only contain information on the last time you started Minecraft, not any previous runs.


    • User
    • 4 forum posts
    Danbearpig
    #3

    Apr 23 19, 12:40 AM

    Thanks, I'll try that. It's a huge mod pack, so it'll take some trial and error, especially since the installer is via Twitch. 3.0.8 didn't crash, but I can't see the menu at the start screen to access replays (the recording indicator shows, and it writes files to replay_recordings, and I found YouTube videos of RM being used with SevTech, but not with advice on how they made it work!). I'll make a fresh 3.1.1 install via Twitch, add OptiFine and ReplayMod, and start pruning mods and hope it doesn't break something else to the point that new crashes override this one...


    • User
    • 4 forum posts
    Danbearpig
    #4

    Apr 23 19, 08:30 AM

    Here you go:

    https://pastebin.com/MZS3hz6i

    There wasn't an "fml-client-latest.log" but there was a "latest.log" in the folder containing the SevTech instance (Twitch doesn't install it in the .minecraft folder, so no logs are being generated there when I play SevTech). I also have the crash log:

    https://pastebin.com/50JEUTZe

    I removed mods in clumps by alphabet to keep track easily, and ended up with ReplayMod, Optifine to satisfy its dependency, and JustEnoughIds-1.0.2-26 as the only mods in the mods folder. Again, this follows installing SevTech 3.1.1 via Twitch, removing BetterFPS to avoid an Optifine conflict, and adding Optifine_1.12.2_HD_U_E3 and replaymod-1.12.2-2.1.4. There are no shaderpacks installed. Every crash report refers to "NoClassDefFoundError: net/minecraft/renderer/entity/RenderTippedArrow".

    I hope this helps, let me know if this is not the log you are looking for...


    • Developer
    • 1883 forum posts
    johni0702
    #5

    Apr 23 19, 09:44 AM

    Ah, yes, I remember some bug which only triggered when JEID is installed. Give this snapshot version of the RM a try, it should have a fix for that bug.

    In case you haven't figured out the main menu: That's probably the CustomMainMenu mod, see here.



    • User
    • 4 forum posts
    Danbearpig
    #6

    Apr 23 19, 06:16 PM | Last edited: Apr 23 19, 06:16 PM

    You are a legend. That snapshot version worked like a charm (added to a clean SevTech 3.1.1 install, looks like JEID was added with 3.1.0), worked a bit with the CustomMainMenu config file and it's a complete success! I must've scrolled right past that bit in the documentation. Tested it and I can view the replay and it looks great. Thank you so much for everything you do, this mod is amazing!