Replay Mod Forums

Crash when selecting export path location
    • User
    • 4 forum posts
    MineThing
    #1

    Apr 23 19, 05:53 PM

    2.1.4 is crashing when I try and select an export location, with the Error "Error: java.lang.NullPointerException: Rendering Gui" (full logs below). Apart from that, it works perfectly and can render things just fine with no crashing. On another thread, you told the person to try with 2.1.3 as you changed a lot of the code for 2.1.4. This worked for me, but when rendering a replay with shaders enabled (using the latest version of optifine for 1.12.2, tried with different FFmpeg version and different shaders), the resulting file is unusable as it is flashing different colours with only the entities rendered mostly correctly on some occasions. See these videos (warning: flashing images):
    No Shaders: https://youtu.be/cTWzTnEV5ac
    Shaders: https://youtu.be/wg84th3NhSw
    Different Shaders: https://youtu.be/AEvBKpQyNKk

    I presume that it is something I am doing wrong. The Ideal solution is to get 2.1.4 working so that I can select the output location and name of the file without it crashing, but fixing the shader issue on 2.1.3 is just as useful for me.

    If you would prefer to fix 2.1.4, here is a video showcasing the issue:
    https://youtu.be/aRCZcugaw-4

    Crash report: https://gist.github.com/MineThingIssues/9d3e8b4ccad3510c4adaef571405ef0a
    Export.log: https://gist.github.com/MineThingIssues/f3d91c1b61f2991f1bf07e0e0738470e

    If there is any more information you would like, please tell me and I will get it for you as soon as possible.
    If you feel that it is necessary to video call and screen share to sort out the issue faster, here is my discord tag: Mine Thing#9452
    My timezone is BST (British Summer Time) and I am available most afternoons/evenings in my timezone.

    Thank you for your time and cooperation,
    Mine Thing


    • User
    • 4 forum posts
    MineThing
    #2

    Apr 23 19, 10:03 PM

    Ok I did some more testing and here are my results:

    1.12 - 2.1.4 - No Optifine - Same issue
    1.12.2 - 2.1.4 - No Optifine - Same issue
    1.12 - 2.1.4 - Optifine - Same issue
    1.12.2 - 2.1.4 - Optifine - Same issue

    Not much to take from that apart from that it is consistent across different Minecraft versions and is not to do with incompatibilities with optifine.

    Hope this helps narrow it down,
    Mine Thing