Replay Mod Forums

1.7.10 crash when loading into replay + hand stays
    • User
    • 7 forum posts
    Dazinq
    #1

    Jul 08 19, 12:25 AM

    So whenever I load into the Replay Viewer, my game will continue to crash. This happens pretty frequently and I don't know what the cause of it would be, I've tried turning down any unnecessary settings and tried searching through the forums to find a fix but couldn't find anything. I can get it usually after the first couple of crashes but it's just really annoying after a while you know? Here's all that info you guys can use to try and resolve the problem.

    Spoiler: Crash Log



    Verison of ReplayMod: replaymod-1.7.10-2.2.0-b5
    OS: Windows 64x
    Version of Forge: forge-1.7.10-10.13.4.1558-1.7.10-installer-win
    Verison of Java: Verison 8 Update 211 (build 1.8.0_211-b12)

    Spoiler: Other Mods Installed



    ALSO:

    Here's a video of what happens when I try to render out a clip, the hand is in the whole animation and I've tried to turn invisibility on and off but it still wont work.




    If i can try to get into the viewer I'll post some screenshots of what I see while keyframing around.

    Anyways thank you guys and I hope I can get this mod running again I have TOO many visions I want to lay out as soon as I can! I know working on an older verison is tedious and I just want to say that I appreciate you guys for your support.


    • Developer
    • 1882 forum posts
    johni0702
    #2

    Jul 08 19, 12:38 PM

    For the crash, please see my reply in this thread and report back whether it works for you.

    The hand issue is caused by OF breaking the forge event which we use to prevent the hand from rendering.
    We already have a workaround for that (we are patching OF while it is loading).
    The OF version you're using is old, really old, it doesn't even have the shaders mod integrated. Try updating (for shaders we only support the ones integrated into OF since the dedicated mod died somewhere around 1.8).


    • User
    • 7 forum posts


    For the crash, please see my reply in this thread and report back whether it works for you.

    The hand issue is caused by OF breaking the forge event which we use to prevent the hand from rendering.
    We already have a workaround for that (we are patching OF while it is loading).
    The OF version you're using is old, really old, it doesn't even have the shaders mod integrated. Try updating (for shaders we only support the ones integrated into OF since the dedicated mod died somewhere around 1.8).


    love you


    • User
    • 7 forum posts


    For the crash, please see my reply in this thread and report back whether it works for you.

    The hand issue is caused by OF breaking the forge event which we use to prevent the hand from rendering.
    We already have a workaround for that (we are patching OF while it is loading).
    The OF version you're using is old, really old, it doesn't even have the shaders mod integrated. Try updating (for shaders we only support the ones integrated into OF since the dedicated mod died somewhere around 1.8).


    The problem loading into a clip is fixed but the hand issue hasnt gone away. but i did find out that it actually doesn't have to do with optifine. While i was installing another verison of Optifine I decided to delete the shadersmod and optifine thinking shadesr would be installed already through optifine. The hand was missing which was amazing but no shaders mod. So i downloaded a new ShadersModCore and sure enough the hand came back.


    • Developer
    • 1882 forum posts

    Well, yes, it has to do with the Shaders code which has been integrated into OF since some time around 1.8 (and iirc it was also backported to 1.7.10), so presumably the same issue also exists with the shaders mod before it was integrated into OF (but our workaround doesn't apply to it).
    Anyway, the only form of shaders which we currently support are the ones integrated into OF. There exists code in the RM specifically for supporting shaders in OF on 1.7.10, so I'm fairly sure that recent 1.7.10 versions of OF have shaders integrated.